Resolved
This degradation has been resolved.
Monitoring
The team has identified a mitigation and released a fix. We are seeing error rates reducing and request times are improving. The team is monitoring the situation.
Investigating
An upstream outage is causing degraded performance with file upload and slower than normal response times. The team is investigating the issue.